Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 15, 2025 - 08:00 UTC
Scheduled
Dear Customers,
On Monday, 15th July 2025, we’ll be upgrading our main phone system to improve reliability and performance.
As part of this upgrade, our main number, 0333 996 1000, may be briefly unavailable during the day while the switchover takes place.
You can continue to reach us throughout the day on our local number: 01925 910080, or email us at support@kloud9.co.uk – our team will continue to monitor messages as usual.
We appreciate your patience while we complete this essential work, and thank you for bearing with us.
The Kloud9 Team
Posted Jul 14, 2025 - 11:46 UTC
This scheduled maintenance affected: Kloud9 VoIP Platform.