Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2025 - 05:00 UTC
Scheduled
Dear Customer,
We have been notified about a planned power outage affecting the Waterhouse Gardens area that is due to occur on 08/09/2025 between 04:00 to 06:00. During this time, you may experience a loss of service.
Please note: No access to your premises is required to resolve this issue.
If you have any questions or need assistance, please call our support team on 0333 996 1000, and we will be happy to help.
Kind regards, Kloud9 Support
Posted Sep 05, 2025 - 10:34 UTC
This scheduled maintenance affected: Waterhouse Gardens.