Manchester Outage

Incident Report for Kloud9

Resolved

This incident has been resolved.
Posted Sep 21, 2025 - 12:52 UTC

Investigating

Dear Customer,

We are currently experiencing a full site outage affecting your area. Our network team is working to resolve the issue as quickly as possible.

Please note: We do not need access to your premises to complete this work.

If you have any concerns or queries, please call 0333 996 1000 and we will be happy to assist.

Kind regards,
Kloud9 Support
Posted Sep 16, 2025 - 16:55 UTC
This incident affected: Print Press, The Cresent, Burlington Square, Transmission House, and Castle Irwell.