Power Outage - Clun

Incident Report for Kloud9

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 10:12 UTC

Investigating

Dear Customers,

An unplanned power outage at our local exchange is affecting service in your area. Please see below for the link to the National Grid website, which contains the details of the power outage.

National Grid reference: https://powercuts.nationalgrid.co.uk/SY78JW

If you have any concerns or queries, please call 0333 996 1000 or email support@kloud9.co.uk, and we will be happy to assist.

Kind regards,
Kloud9 Support
Posted Sep 15, 2025 - 07:07 UTC
This incident affected: Clun.